For Talkative scripts to function correctly, we have in place the following system requirements. These requirements need to be met for our chat widgets to appear on customer devices. Please be advised, as future updates come out, we may increase these requirements to maintain full support.


We can support a wide variety of operating systems and use the browser version for compatibility. Here are a list of browsers and versions supported below:


BrowserMinimum Supported Version
Google Chrome90
Microsoft Edge90
Safari14.0
Firefox100
Samsung Internet15